Page 5 of 5 FirstFirst ... 345
Results 101 to 122 of 122
  1. #101
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Seems like a lot of us also own Elements .This was ours until yesterday when we traded for a 2015 Fit LX .Owned since new , 2003 4wd Y model .First one sold at Hanover Honda .Happy to get the new car , very sad to see the E go :

  2. #102
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    The new car :

  3. #103
    Wagonist TheGreatBacon's Avatar
    Join Date
    Sep 2012
    Location
    queen shitty, nc
    Posts
    296
    Nice, I just picked up a 2015 EX 6MT last month!
    Instagram:EFCIVICSEDAN

  4. #104
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Nothing to add , been busy on my other project .The snow is finally gone so we will be getting the wagon out of the garage and on the road soon .A lot of garage grime to clean off first though .The fit has been a great car so far .Put on the rear splash guards yesterday , they look really good .

  5. #105
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    All cleaned up and on the road again .

  6. #106
    Senior Wagonist SPW's Avatar
    Join Date
    Jan 2012
    Location
    Saint Petersburg, FL
    Posts
    801
    Very nice. Great work!

  7. #107
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Thanks , we really enjoy this car .

  8. #108
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    We drove the car all spring summer and now fall . Ran really well , but now it is time to put it away for winter .I hope to hook up the AC and power steering over the winter .I am pretty well stymied on getting the MPFI to work , but maybe I will have time to look at that again .The car has held up well , other than one small bit of surface rust on the passenger front door , it looks like the day it was painted .

  9. #109
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Put the wagon in the shed with the other summer stuff .Hopefully I will get a few things done to it over the winter .

  10. #110
    Band Wagon
    Join Date
    Dec 2014
    Location
    Portland
    Posts
    46
    I love those little t@b trailers! I built my own 4x8 teardrop I pull with my wagon.

  11. #111
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    The T@B is awesome , had it out to Nova Scotia this year .But we pull it with a Honda Pilot .

  12. #112
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Wagon is back on the road again .Unfortunately I did not have time to do anything to it this year but it is running great .Started right up and the noise that was coming from the right rear passenger wheel area when turning left seems to have gone away and the transmission no longer wants to get hung up in first gear .Getting better with age LOL .

  13. #113
    Wagonist
    Join Date
    Jan 2013
    Location
    Murfreesboro, Tn
    Posts
    232
    Awesome work with the rust man!

  14. #114
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Thank you .

  15. #115
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Had to replace the windshield the other day .Had a bad crack in the driver side lower corner and foggy patches .Got the old screen taken out and the culprit was rust .Took it back home and welded some patches in and took it back in a week later after the new paint was fully cured :

  16. #116
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Some of the rust :

  17. #117
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    New windshield in .The old moulding was glued in by the last hack that put the windshield in , so it got destroyed .I could not get new trim so it has universal stuff on now .Matches everywhere but the upper corners , I filled that with a bit of black urethane .Really not that noticeable , and I think the old moulding caused water to pool under it and caused the rust .

  18. #118
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    It has been a while since my last post. I have not had much time to do anything on the wagon except enjoy driving it. But this winter I decided the wagon gets the primo spot in the garage and the goal is to get the power steering working. Picked up a rebuilt rack from Canadian Tire and got a crank pulley from wrecker near London to replace the one I managed to break. All the old metal lines are rotted and the cooler too. I am waiting for a seal kit for the pump but I am thinking it might be OK. So making new lines is going to be the hard part.
    The other project is going to be installing the roof rack that I bought from a member here. It is a USDM dealer install rack. I like the Yakima rack we have on now but I think the built in rack will be nice. Will get some pics up as some progress is made.

  19. #119
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    I have the new power steering rack in and plumbed up. Did not take a lot of pictures but really not much excitement there. I had to make up two of the three hoses and search Ebay for some of the connectors. One line is a left over braided oil feed from a turbo, another is some fuel injection line and the pump to rack line was available complete from Ebay and is a copy of OEM and fit perfect.Left to do is put the steering links to the spindles back on and connect the collumn to the rack. The car needs new axles (maybe just replace the ripped boots) and possibly an axle seal. So I will get those parts and go back to crawling under the car then. Had to replace the flex pipe on the exhaust,old one rotted out. The new one has a much bigger ID so should pick up a bit more power I hope. I have some pics to post, but it has been a while and I can't figure it out. IMG_6408.JPG
    Last edited by wftb; 02-07-2019 at 04:14 AM.

  20. #120
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    You must be posting in this thread by mistake. We are a long ways from Peru lol.

  21. #121
    Band Wagon
    Join Date
    Jul 2016
    Location
    Sweden
    Posts
    39
    Such a clean Wagon! How is it finding replacement windscreens? Are they still manufactured or do you have to source second hand ones?

  22. #122
    Wagonist
    Join Date
    Jun 2013
    Location
    kincardine canada
    Posts
    170
    Here in Ontario Canada it was no problem getting a new windscreen but that was over 2 years ago. Cost was 300.00 installed. Still made as far as I know. Thanks for the post.

Similar Threads

  1. wagon build up from Ontario Canada
    By wftb in forum New User Introductions
    Replies: 9
    Last Post: 01-27-2014, 04:06 PM
  2. Jon-wa-GO-van's Auto-X Blog/Build
    By Dash-N-Cars in forum Competition & Motorsport
    Replies: 27
    Last Post: 04-17-2011, 07:09 PM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •